Donate!
Welcome, Guest. Please Login or Register :: View Members
Pages: 1
Send Topic Print
Tach install/horn problem ? (Read 54 times)
zipidachimp
Serious Thumper
*****
Offline

SuzukiSavage.com
Rocks!

Posts: 943
surrey, b.c.
Gender: male
Tach install/horn problem ?
06/28/20 at 00:23:50
 
Fiamm horn/Ryca tach:  12 volts across horn is bloody loud. After Ryca install per instructions, horn gives nothing but a very weak 'meep meep' . Yes, wires are per photos posted here. Tach makes a full sweep with key on. Sad
This is actually the second time I've done this. Last time a year ago no problem.
Frustrating!
Back to top
 
 
  IP Logged
Dave
YaBB Moderator
ModSquad
*****
Offline

SuzukiSavage.com
Rocks!

Posts: 15437
Camp Springs, Kentucky
Gender: male
Re: Tach install/horn problem ?
Reply #1 - 06/28/20 at 04:10:47
 
Do the RYCA instructions use the horn wire for a power supply?  Does the horn work normally when you remove the tach wire?  Did you connect the wire to the "Positive" wire to the horn.....or to the "Button" side"  If you connected to the button side the power must pass through the tachometer wiring before it can power the horn......that won't work well.

Check the wiring and make sure you have the tach wire connected to the correct wire at the horn.
Back to top
 
 

Someday I will be old......But not today!

  IP Logged
zipidachimp
Serious Thumper
*****
Offline

SuzukiSavage.com
Rocks!

Posts: 943
surrey, b.c.
Gender: male
Re: Tach install/horn problem ?
Reply #2 - 06/28/20 at 10:58:10
 
forgot to mention that the tach is mounted through a 2.5" rubber grommet, no connection to the frame except the central wires! Will correct this tomorrow. Sorry!  Embarrassed
Different from last year!
Back to top
 
 
  IP Logged
Yoshi
Serious Thumper
*****
Offline

SuzukiSavage.com
Rocks!

Posts: 777
LongIsland, N.Y.
Gender: male
Re: Tach install/horn problem ?
Reply #3 - 06/30/20 at 20:24:31
 
If i remember correctly i ran all my wires directly to the coil, nothing to the horn
Back to top
 
 
  IP Logged
zipidachimp
Serious Thumper
*****
Offline

SuzukiSavage.com
Rocks!

Posts: 943
surrey, b.c.
Gender: male
Re: Tach install/horn problem ?
Reply #4 - 07/02/20 at 20:31:39
 
Back in the garage, disconnected tach, weak beep from horn, lights blink when horn button pushed. Worked last year, not now.
Problem between horn and button. Any ideas?
Horn works when off the bike.
Cheers  Angry
Back to top
 
 
  IP Logged
Dave
YaBB Moderator
ModSquad
*****
Offline

SuzukiSavage.com
Rocks!

Posts: 15437
Camp Springs, Kentucky
Gender: male
Re: Tach install/horn problem ?
Reply #5 - 07/03/20 at 03:06:56
 
Sounds like a weak battery, poor ground, or dirt switch.

Do you have a voltmeter?
Back to top
 
 

Someday I will be old......But not today!

  IP Logged
Gary_in_NJ
Serious Thumper
*****
Offline

LS650 Cafe Racer

Posts: 2030
Amongst the Twisty Roads
Re: Tach install/horn problem ?
Reply #6 - 07/03/20 at 06:19:26
 
From the RYCA instructions. Take note of the older model/new model differences:

If you are using both the speedometer and tachometer of the kit, the red and black wires of both gauges can be tied together to simplify wiring.
The black wires connect to ground (you can use the screw holding the ignition coil as a ground). The red wires can be tied to the blue wire of the tachometer and run to the horn circuit. The horn connection wire color will depend on the year model of your bike:
Older models: use the orange wire of the horn (green wire is not used).
Newer models: use the red / black wire of the horn (blue / black is not used).

The green wire of the tachometer connects to the negative terminal of the ignition coil.

Back to top
 
 

A life-time student of motorcycling. LS650 Cafe, TS-Z400, FZ6
My LS650=> http://suzukisavage.com/yabb2.2/Attachments/Left.JPG
  IP Logged
zipidachimp
Serious Thumper
*****
Offline

SuzukiSavage.com
Rocks!

Posts: 943
surrey, b.c.
Gender: male
Re: Tach install/horn problem ?
Reply #7 - Yesterday at 23:46:45
 
Tach wiring is OK. From another source,  I may have a faulty horn relay/switch. I may just buy a separate switch and relay and wire it in direct.
Cheers!  Cool
Back to top
 
 
  IP Logged
Pages: 1
Send Topic Print


« Home

 
« Home
SuzukiSavage.com
07/05/20 at 02:46:54



General CategoryRubber Side Down! › Tach install/horn problem ?


SuzukiSavage.com » Powered by YaBB 2.2!
YaBB © 2000-2007. All Rights Reserved.